HP Forums

Full Version: Wp34s firmware update problem
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hello, after a long time (years) I got curious and decided to upgrade my wp34s, which was still at the latest "official" 2015 version. But what do they say about curiosity? Either I forgot how to do it, or something changed, anyway I can't seem to flash it, and I apparently bricked my calculator.
I'm using Linux, so I use the multi-platform tool.
I connected the cable, then I prepared the calculator by On+D then On+S+S. The screen went off, I pressed On. As expected, I got nothing on the display.
But when I try to run the flash tool... I get a "can't connect" error. I also tried the "Reset + On" trick, still no joy. The command I ran is

sudo ./wp34sflashcmd calc_full.bin /dev/ttyUSB1

And yes, I checked that ttyUSB1 is the correct port for the adapter.
Any hints on what to check next? The calculator was working very well, but I can't rule out some failure on the cable, though the pogo pins seem to be in excellent shape...

OK, never mind. I managed to find an old laptop with an hardware serial port, and succeeded to flash using MySamba. Maybe my USB<->Serial adapter is not compatible with the Linux tool.
Sadly, before finding that laptop, I suspected a bad connection between the cable and the calculator, so I tried to open the calc to clean the contacts. Turns out they were dirty indeed, but while opening the case, I forgot the two screws under the rubber strip, so I snapped the top face-plate in two. The calc still works, but two rows of pixels look "washed out". And one key lost its "click". So I made a new Wp34s using a boxed, brand new HP30b I had in my collection. I was a bit sad having to open the sealed box, but after seeing the price for as-new units (130€ in Europe) I have no regrets... Smile Let's say that's the price I had to pay for my haste and carelessness, and I hope the lesson is learned.

Unfortunately, the multi-platform flash tool is not reliable. As far as I know, it sends the exact same bytes as MySamba at the same speed and was written by looking at the original code.
I have never been able to found why.
I use mysamba.exe running under wine on my Linux machine and it works great. In fact I like this arrangement better than running mysamba.exe under Windows, because Linux has a smarter more consistent naming convention for USB serial ports. The port always appears as COM6: (/dev/ttyUSB0) under Linux (where I have com6: symlinked to /dev/ttyUSB0 in the .wine/dosdevices/ directory), but under Windows it can appear as COM11:, or COM12: or COM13: and it takes some extra testing and fiddling around to find out what the connected port name is under Windows. Since mysamba.exe remembers the last port name you used, everything works the first time every time with Linux.
Reference URL's