HP Forums

Full Version: Bug in "apply"
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
When I have: matrix m1 and do: apply(x->sin(x),row(m1,1)), OK, but when I do apply(x->sin(x),row(m1,1)*pi/180) or apply(x->sin(x*pi/180),row(m1,1)) it crashes the VC, it does not matter if I do * or .*. BTW I have the latest version of VC.
I tried both versions using matrix M1 where I have data in, they worked. Then I made a matrix m1:=[[1,4],[5,7]] and they worked.
I did the same thing as Arno. No problem here, either. In earlier firmware, after a lot of activity I found it necessary to use the VC menu bar:

Calculator | Reset.

This seemed to clear weird problems including crashes where, otherwise, the VC would not crash. On the latest firmware, I haven't had to do that, so this may not help.

Thank you all.
I "restarted" the VC and now it works. What it was doing before was that VC hanged up and when I pressed "ON" the VC crashed.

Reference URL's