HP Forums

Full Version: pyIPER PIL-Box command error: illegal retval
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I'm attempting to run pyILPER 1.6.0 on Linux Mint 18.3 and connect to my home built PIL-Box running v2.1. I followed the directions to install miniconda and pyILPER. I get this error on start: "PIL-Box command error: illegat reval" on a reconnect the error is "Cannon connect ot PIL-Box: PIL-Box command error: illegal retval".

I've tried all Baud settings. My user is in the dialout group. pyILPER seems to be seeing the serial device as the error is different if I configure the wrong one on purpose.
The error is thrown if the return value the PIL-Box sends after it got a command has not the expected value. In most cases this is a baud rate related problem which you have already checked. Is there any other serial device pyILPER is accidently connected to?
I've checked my USB-serial converter for proper operation, and then modified it to provide 5 volt signals as it was set to 3.3 volts. I have also tried it on a Windows computer with the error that the PIL box is not respondingl I believe the baud rate is correct but my ancient oscilloscope failed before I could measure the actual signal!

I currently suspect a wiring mistake on my part.
Reference URL's