Post Reply 
Calculator name bug in Beta
12-04-2017, 10:20 AM
Post: #1
Calculator name bug in Beta
In the old release, if your calculator has the same name as the virtual machine on the PC, it detected 2 calculators. However, in the beta it only shows one. I had to start the virtual one, change the name (Settings), close it and open it again. Then it had the new name and then I'd plug in the physical calculator showing both names.
Find all posts by this user
Quote this message in a reply
12-04-2017, 01:44 PM
Post: #2
RE: Calculator name bug in Beta
I don't think this is a "bug": why two calculators should have the same name?
When both of them are in the list with the same name it is no easy to distinguish...
My Prime (HW, emu, iOS) have the same programs and vars: it would be almost very difficult for me operate with them if they'd have the same name...

Salvo

∫aL√0mic (IT9CLU), HP Prime, 50g, 41CX, 42s, 15C, 12C, DM42 :: Prime Soft. Lib
Find all posts by this user
Quote this message in a reply
12-04-2017, 06:23 PM (This post was last modified: 12-04-2017 06:24 PM by Tim Wessman.)
Post: #3
RE: Calculator name bug in Beta
(12-04-2017 10:20 AM)webmasterpdx Wrote:  In the old release, if your calculator has the same name as the virtual machine on the PC, it detected 2 calculators. However, in the beta it only shows one. I had to start the virtual one, change the name (Settings), close it and open it again. Then it had the new name and then I'd plug in the physical calculator showing both names.

Have you cloned your hardware calculator to your emulator? If so, the serial number of the clone came along with it. Check your "About HP Prime" screen on the emulator and I suspect it will match your HW. This is why it shows up the same. In your emu, just delete the "settings" file and you should be good again.

We haven't figured out what to do regarding the serial number in clones. There are drawbacks to just discarding it at any time and loading the old one...

TW

Although I work for the HP calculator group, the views and opinions I post here are my own.
Find all posts by this user
Quote this message in a reply
12-04-2017, 07:40 PM (This post was last modified: 12-04-2017 08:03 PM by Arno K.)
Post: #4
RE: Calculator name bug in Beta
(12-04-2017 06:23 PM)Tim Wessman Wrote:  
(12-04-2017 10:20 AM)webmasterpdx Wrote:  In the old release, if your calculator has the same name as the virtual machine on the PC, it detected 2 calculators. However, in the beta it only shows one. I had to start the virtual one, change the name (Settings), close it and open it again. Then it had the new name and then I'd plug in the physical calculator showing both names.

Have you cloned your hardware calculator to your emulator? If so, the serial number of the clone came along with it. Check your "About HP Prime" screen on the emulator and I suspect it will match your HW. This is why it shows up the same. In your emu, just delete the "settings" file and you should be good again.

We haven't figured out what to do regarding the serial number in clones. There are drawbacks to just discarding it at any time and loading the old one...
That seems not to be the problem, I have cloned my VC using a backup from HW, both show up in CK when connected and they have the same serial-no (checked that right now).
Arno
Find all posts by this user
Quote this message in a reply
12-04-2017, 09:00 PM (This post was last modified: 12-04-2017 09:01 PM by Arno K.)
Post: #5
RE: Calculator name bug in Beta
The problem here is only naming, my Android got, after latest install, a backup replayed with all my newest changes, so I now started the connkit, VC and HW showed up and Android said "No adapter found", it still had the name of my HW-Prime. I changed it to something else and all three showed up in the connkit, although they are the of the same serial.
Find all posts by this user
Quote this message in a reply
Post Reply 




User(s) browsing this thread: 1 Guest(s)