Post Reply 
New Version: 2014.0702 (EXTREMLY MINOR - SS410 USERS ONLY)
08-19-2014, 07:30 PM (This post was last modified: 08-19-2014 07:36 PM by Tim Wessman.)
Post: #1
New Version: 2014.0702 (EXTREMLY MINOR - SS410 USERS ONLY)
Hello,

You may see an update pop up in the connkit shortly. This is only calculator firmware and only applies to users who are using the StreamSmart 410. If this is not you, I'd recommend not installing it as there is no reason to do so. If your streamers are working fine, no need to install it either.

Basically, it turns up the provided power on the USB port when the streamer is in use since some people had issues with the streamer not working when the battery was completely drained. It would start working after about 3 minutes or so, but this will fix that so it will work immediately.

The revision number changed by 1.

Please do not ask when/if/what future updates will come out. That is information that cannot be given.

Quote:Internal Versions
-----------------
Firmware Version: 2014 07 02 (6031)
Virtual Calculator Version: 2014 03 31 (6031)
Connectivity Kit: 2014 03 31 (6026)

Description
-----------
This release of the HP Prime Graphing Calculator firmware addresses issues related to sensor detection when using the HP StreamSmart 410 (NW278AA). Only the Prime Data Streamer application on the calculator has changed. The Virtual Calculator and Connectivity Kit have not changed.

Backward Compatibility
----------------------
This release only applies to the HP Prime Graphing Calculator (G8X92AA) and StreamSmart 410 (NW278AA). There is complete backward compatibility.


Target Customer
----------------------

This release is for customers using the HP StreamSmart 410 (NW278AA). This is an optional release for customers who are not using the HP StreamSmart 410 (NW278AA).

New Functionality (Connectivity Kit)
------------------------------------
None.

New Functionality (Calculator Software)
---------------------------------------
None.

New Functionality (Virtual Calculator)
--------------------------------------
None.

Resolved issues and changes excluding CAS
-----------------------------------------
1. When utilizing the HP StreamSmart 410 (NW278AA), the HP Prime Graphing Calculator (G8X92AA) now provides power over the USB port.

TW

Although I work for the HP calculator group, the views and opinions I post here are my own.
Find all posts by this user
Quote this message in a reply
08-19-2014, 07:45 PM (This post was last modified: 08-19-2014 07:45 PM by Tugdual.)
Post: #2
RE: New Version: 2014.0702 (EXTREMLY MINOR - SS410 USERS ONLY)
Hey Tim that's cool but you also deserve vacation. Go now Smile
Find all posts by this user
Quote this message in a reply
08-19-2014, 09:58 PM
Post: #3
RE: New Version: 2014.0702 (EXTREMLY MINOR - SS410 USERS ONLY)
I hope future updates will come out.
Find all posts by this user
Quote this message in a reply
08-20-2014, 08:41 AM
Post: #4
RE: New Version: 2014.0702 (EXTREMLY MINOR - SS410 USERS ONLY)
Only one question:
when/if/what future updates will come out?

My website: erwin.ried.cl
Visit this user's website Find all posts by this user
Quote this message in a reply
08-20-2014, 03:41 PM
Post: #5
RE: New Version: 2014.0702 (EXTREMLY MINOR - SS410 USERS ONLY)
(08-20-2014 08:41 AM)eried Wrote:  Only one question:
when/if/what future updates will come out?

PHHHHBT! :-P

TW

Although I work for the HP calculator group, the views and opinions I post here are my own.
Find all posts by this user
Quote this message in a reply
08-22-2014, 05:56 PM (This post was last modified: 08-22-2014 05:56 PM by Mic.)
Post: #6
RE: New Version: 2014.0702 (EXTREMLY MINOR - SS410 USERS ONLY)
When will a stable firmware be released ? The last firmwares often freeze the calc... I think this is a priority.

http://mic.nic.free.fr - Youtube - Facebook
Find all posts by this user
Quote this message in a reply
08-24-2014, 04:58 PM (This post was last modified: 08-24-2014 05:02 PM by Thomas_Sch.)
Post: #7
RE: New Version: 2014.0702 (EXTREMLY MINOR - SS410 USERS ONLY)
(08-22-2014 05:56 PM)Mic Wrote:  When will a stable firmware be released ? The last firmwares often freeze the calc... I think this is a priority.

Are all errors/freezes that you found, already listed in the Collection at tricider:
http://www.tricider.com/brainstorming/2eKfifdjarx ?
Find all posts by this user
Quote this message in a reply
08-25-2014, 05:48 AM
Post: #8
RE: New Version: 2014.0702 (EXTREMLY MINOR - SS410 USERS ONLY)
Very good iniative Smile

http://mic.nic.free.fr - Youtube - Facebook
Find all posts by this user
Quote this message in a reply
08-26-2014, 11:45 AM
Post: #9
RE: New Version: 2014.0702 (EXTREMLY MINOR - SS410 USERS ONLY)
Yes, indeed.
Erwin (eried) started this mentioned at http://www.hpmuseum.org/forum/thread-1817.html
Find all posts by this user
Quote this message in a reply
08-30-2014, 06:06 AM (This post was last modified: 08-30-2014 06:07 AM by Tugdual.)
Post: #10
RE: New Version: 2014.0702 (EXTREMLY MINOR - SS410 USERS ONLY)
(08-24-2014 04:58 PM)Thomas_Sch Wrote:  
(08-22-2014 05:56 PM)Mic Wrote:  When will a stable firmware be released ? The last firmwares often freeze the calc... I think this is a priority.

Are all errors/freezes that you found, already listed in the Collection at tricider:
http://www.tricider.com/brainstorming/2eKfifdjarx ?
Yep it does freeze. I just added in the report the one that is caused by tapping screen when displaying heavy functions. Tim is aware of this one he is the one who suggested to leave fingers on screen and not tap. Was hoping to get this rapidly fixed because until now the only cure is to stab the machine in the back with a paper clip...
When will this critical bug be fixed? PHHHHBT! (2014 Hp marketing, nice)
Find all posts by this user
Quote this message in a reply
09-21-2014, 09:54 AM
Post: #11
RE: New Version: 2014.0702 (EXTREMLY MINOR - SS410 USERS ONLY)
I have updated my firmware to 6031 on a A hardware versión unit by mistake.

Is there a way to downgrade to 6030 versión? Or I should not have to worry about that?

Thanks everybody.
Find all posts by this user
Quote this message in a reply
09-21-2014, 11:20 AM
Post: #12
RE: New Version: 2014.0702 (EXTREMLY MINOR - SS410 USERS ONLY)
You don't have a TI-Nspire, so you don't need to worry about that Smile
Find all posts by this user
Quote this message in a reply
09-22-2014, 04:02 PM
Post: #13
RE: New Version: 2014.0702 (EXTREMLY MINOR - SS410 USERS ONLY)
(09-21-2014 11:20 AM)debrouxl Wrote:  You don't have a TI-Nspire, so you don't need to worry about that Smile
Actually shipping nspire CXes still seem to come (mostly) with pre-June firmware update so ndless works perfectly... you just won't be able to multi-boot firmware revisions/versions unless you find an older nspire CX(or don't upgrade an old greyscale nspire past I forget which update ATM... my used nspire that I picked up is 2.00 and I'm leaving it there...)
Find all posts by this user
Quote this message in a reply
09-22-2014, 04:20 PM
Post: #14
RE: New Version: 2014.0702 (EXTREMLY MINOR - SS410 USERS ONLY)
The Nspire's anti-downgrade protection is a concern even for calculators still equipped with OS 3.6.0.546/550: it forbids downgrading to OS 3.1.0.392, which is faster in some aspects Smile
And hardware revision J or later Nspire CX calculators suck for user freedom.
Find all posts by this user
Quote this message in a reply
09-25-2014, 05:22 PM
Post: #15
RE: New Version: 2014.0702 (EXTREMLY MINOR - SS410 USERS ONLY)
Re: the 6031 firmware

I have my Prime running on 6031 and have experienced no problems. The "kit" did the upgrade when I first installed and I just "followed orders" before learning that the 6031 was intended for "wireless" Primes (which, considering h/p's advertising, I thought I had).

I have had none of the "whole memory gone" on paperclip-reset mentioned in the forum, but I just give a quick tap, not a push and hold. YMMV

D
Visit this user's website Find all posts by this user
Quote this message in a reply
09-26-2014, 12:30 AM (This post was last modified: 09-26-2014 12:39 AM by Kevin Ouellet.)
Post: #16
RE: New Version: 2014.0702 (EXTREMLY MINOR - SS410 USERS ONLY)
(09-22-2014 04:20 PM)debrouxl Wrote:  The Nspire's anti-downgrade protection is a concern even for calculators still equipped with OS 3.6.0.546/550: it forbids downgrading to OS 3.1.0.392, which is faster in some aspects Smile
And hardware revision J or later Nspire CX calculators suck for user freedom.

That and since many young and impatient Nspire users will want to play Pokémon, then they will rush their downgrade, flashing or Ndless install without reading all instructions carefully and unlike with the TI-Z80 and 68K models, as well as HP and Casio models, the potential for permanently bricking their TI-Nspire CX is incredibly high. With a 83+, 89T, 9860G or to a lesser extent a PRIZM, all that can happen 99.9999% of the time is a RAM reset.

We can't really blame Ndless for the high Nspires failure rate in the last few years. It would probably not be online anymore if it was the case (at least until it's fixed). It's all TI's fault for forcing people to have to hack their calc that hard in order to run third-party software. Back in the days, there were not 10 threads a month on TI forums about bricked 84+ calculators. In fact, I sometimes wonder if some of the incidents involving Nspires failing lately aren't more because of hardware or software defect, especially the scrambled keypad controls issue.

-DJ Omnimaga
Calculator, mobile & PC game development & art: http://codewalr.us
My music: http://djomnimaga.bandcamp.com/
Visit this user's website Find all posts by this user
Quote this message in a reply
09-26-2014, 01:02 AM (This post was last modified: 09-26-2014 03:17 PM by Don Shepherd.)
Post: #17
RE: New Version: 2014.0702 (EXTREMLY MINOR - SS410 USERS ONLY)
(09-26-2014 12:30 AM)Kevin Ouellet Wrote:  It's all TI's fault for forcing people to have to hack their calc that hard in order to run third-party software.

It's only TI's fault if they promised that their calculators would run any third-party software, authorized or not. I don't think they ever made that promise. I have used third-party software (Zoom Algebra) with my TI-85 for years and have had no problems.

If someone wants to run software that alters the operating system in order to run unauthorized things, they assume the risk inherent in that. Don't blame TI.
Find all posts by this user
Quote this message in a reply
09-26-2014, 06:15 AM
Post: #18
RE: New Version: 2014.0702 (EXTREMLY MINOR - SS410 USERS ONLY)
Quote:the potential for permanently bricking their TI-Nspire CX is incredibly high
Depends on the definition of "permanent bricking" Smile
* bricking Nspires, especially CX models, beyond repair using equipment provided with the calculator out of the box, i.e. the standard USB A <-> mini-B cable, is relatively easy;
* however, bricking Nspires in such a way that they don't boot, and cannot be repaired even through the RS232 TTL port, is very hard.
In order to distinguish the two states, I usually term calculators in the first situation "semi-bricks", while calculators in the second situation are, indeed, permanent bricks, in the current state of our collective knowledge.

The most common cause of a failure to boot is improper boot2 flashing caused by TI's faulty official OS 3.0.1.1753 upgrade, or by users disregarding the three safety warnings in emphasized, red text contained in TI-Planet's tutorial + the warning inside nsNandMgr (sigh). Improper boot2 flashing can easily be fixed under the boot1 through a cheap RS232 TTL adapter, by following a well-defined procedure.
Some of the permanently damaged calculators had received such mishandling as unspecified short-circuits between pins of the dock connector (sound output experiments), or usage of improperly-patched forks of nsNandMgr where all of the safeguards intentionally put into place by critor had been removed.
Find all posts by this user
Quote this message in a reply
10-08-2014, 04:21 PM
Post: #19
RE: New Version: 2014.0702 (EXTREMLY MINOR - SS410 USERS ONLY)
Hello,

I bought the very new StreamSmart 410, together with 4 Fourier sensors...

This little machine works very well together with the "HPPrime-Emulator" (Win 8.1)...

... but my HP Prime
Software Version: 2014 7 2 (6031)
Hardware Version: A
Serial Number: 4CY3450B1W

won't recognise the StreamSmart Hardware (the DataStreamer app is greyed out), even if I try to reset the Hardware etc. pp.

What can / should I do?

Any help would be very nice
Frank (from Germany)
Find all posts by this user
Quote this message in a reply
10-08-2014, 04:30 PM
Post: #20
RE: New Version: 2014.0702 (EXTREMLY MINOR - SS410 USERS ONLY)
Contact support and ask them to help.

TW

Although I work for the HP calculator group, the views and opinions I post here are my own.
Find all posts by this user
Quote this message in a reply
Post Reply 




User(s) browsing this thread: 1 Guest(s)