Post Reply 
WP34s Power Proc-Speed Performance
02-13-2015, 10:01 AM (This post was last modified: 02-13-2015 10:05 AM by MarkHaysHarris777.)
Post: #1
WP34s Power Proc-Speed Performance
Greetings, I suspected that my batt might be low on this used 20b, for several reasons not limited to some flaky behavior, so I decided to take the batt reading under processor load (stress), even though the batt reading at rest was 2.8-2.9/ the code follows, then comment:


LBL  'A01'
LBL  33
DSE  00
GTO  33

Comment: Prior to running this silly counted loop, make sure to load register '00' with some large value... I chose 20,000. The battery annunciator came on almost immediately, the unit shifted into proc 'slow' mode and the program completed in about 150 ticks (fifteen seconds); the posted batt reading was 2.5 at the end of the run.

I decided to run this same program on my other units (currently playing with three of them) the 30b(s) indicate 3.0v at rest; the one gave a stressed batt reading of 2.7 (unit B) (with annunciator flicker) and the other gave a stressed batt reading of 2.6 (A) without annunciator. The units did appear to run at different speeds; however, they were not consistent. Unit A came in at 8.7 seconds, while unit B came in at 14.3 seconds. The second time I ran unit A, it came in at 11.4 seconds.

It would be interesting to know how speed stepping works here. Is there more than one step? Under load does the processor speed toggle depending, or once it steps down does it remain there?

... will be interesting to watch the mA reading (if the silly thing ever gets here).


Kind regards,
Find all posts by this user
Quote this message in a reply
Post Reply 

Messages In This Thread
WP34s Power Proc-Speed Performance - MarkHaysHarris777 - 02-13-2015 10:01 AM

User(s) browsing this thread: 1 Guest(s)