HP Forums
HP 50g+ Emulator - Printable Version

+- HP Forums (http://www.hpmuseum.org/forum)
+-- Forum: HP Calculators (and very old HP Computers) (/forum-3.html)
+--- Forum: General Forum (/forum-4.html)
+--- Thread: HP 50g+ Emulator (/thread-4463.html)

Pages: 1 2


HP 50g+ Emulator - Skyblues - 08-01-2015 05:32 AM

Greetings,

As discussed in the post "Emulator of HP 50g with #2.16 ROM", Hewlett-Packard released an HP-50G emulator that uses ROM version 2.16. I don't know what's different in v2.16 (if anything).

I absolutely love one of the background images used by that emulator. Unfortunately, the problem I discovered with HP's emulator (using ROM version 2.16) was with that I can't load libraries (or, at least, I couldn't figure out how). Without the ability to use libraries, an emulator is worthless to me.

I liked the image so much, I decided to use it and create my own custom emulator. I used the standard 50g ROM image, ROMG+.50G. I have called this emulator HP 50G+.

To create my own version, I started with the HP background image, touched it up to my liking in Lightroom and then used Photoshop to add the annunciator images.

I used Emu48.exe v1.5.3.0 which I believe is the latest.

I spent a lot of time trying to figure out how to write a kml file. It's pretty confusing at first. I read the KML_20 document which was helpful but still left me a bit confused. I reviewed many of the currently available kml files that others have written for HP emulators which helped a lot.

Kudos to the following who's work helped me the most:
1) The Real HP-50g by Grokwik and
2) The Real 50G by Eric Rechlin

I'm sure there are better ways to accomplish what I set out to accomplish but with my limited knowledge, I created two emulator kml files and bitmaps. One uses the lighter LCD used by Grokwik and the other a darker LCD used by Eric Rechlin.

I'm pretty happy with the results so far. If anyone wants to try it out, let me know and I'll PM you the link where the files are located.

I have included two *.e49 files; one for each emulator. This may be unnecessary, I'm not sure. I believe they hold the libraries (which I have also included). I have also included the original bitmap supplied by HP.

If anyone has any suggestions as to how to make it better, please let me know.

Best regards,
Jim


RE: HP 50g+ Emulator - Tim Wessman - 08-02-2015 04:49 AM

If I remembered correctly, it had a new version of the streamer software to support the ss410 (as opposed to the ss400 earlier). Nothing else changed.

Can't you install your library to port 0?


RE: HP 50g+ Emulator - Gerald H - 08-02-2015 05:00 AM

Yes, library can be stored to port 0.

What about port 2?


RE: HP 50g+ Emulator - Skyblues - 08-02-2015 05:05 AM

With other versions of the Emu, I drag/drop a library file to the emulator screen, then store it to a port. When I do the same with the ROM 2.16 emulator, I get an error message "Cannot load an empty file". Hence, I can't even get a library to be recognized on 2.16. Maybe I'm doing something wrong but I'm attempting the same thing that works on other versions of the emulator.


RE: HP 50g+ Emulator - Gerald H - 08-02-2015 05:20 AM

(08-02-2015 05:05 AM)Skyblues Wrote:  With other versions of the Emu, I drag/drop a library file to the emulator screen, then store it to a port. When I do the same with the ROM 2.16 emulator, I get an error message "Cannot load an empty file". Hence, I can't even get a library to be recognized on 2.16. Maybe I'm doing something wrong but I'm attempting the same thing that works on other versions of the emulator.

Yes, drag & drop but not to port 2.

Seems an odd limitation?


RE: HP 50g+ Emulator - Gerald H - 08-02-2015 05:55 AM

(08-02-2015 05:05 AM)Skyblues Wrote:  With other versions of the Emu, I drag/drop a library file to the emulator screen, then store it to a port. When I do the same with the ROM 2.16 emulator, I get an error message "Cannot load an empty file". Hence, I can't even get a library to be recognized on 2.16. Maybe I'm doing something wrong but I'm attempting the same thing that works on other versions of the emulator.

Yes, it works to port 2 on emu48.

The superior genuine HP product seems to suffer from the general abundance of peculiar bugs not found in amateur developments, eg emu48 & WP 34S.

Sadly the genuine HP emulator is free, so probably won't be supported by the producer.


RE: HP 50g+ Emulator - Skyblues - 08-02-2015 05:31 PM

(08-02-2015 05:20 AM)Gerald H Wrote:  
(08-02-2015 05:05 AM)Skyblues Wrote:  With other versions of the Emu, I drag/drop a library file to the emulator screen, then store it to a port. When I do the same with the ROM 2.16 emulator, I get an error message "Cannot load an empty file". Hence, I can't even get a library to be recognized on 2.16. Maybe I'm doing something wrong but I'm attempting the same thing that works on other versions of the emulator.

Yes, drag & drop but not to port 2.

Seems an odd limitation?

How exactly are you doing this? What I usually do is the following:

1) Drag the library file to the emulator LCD
The library shows up on the stack as "Library <number>:<text>"

2) I press <port> STO

3) Soft restart and now have my library available

For the 2.16 emulator, I am stuck at step 1. As soon as I drop the library to the LCD, rather than the library number:name showing up on the stack, I am getting an error dialog "Cannot load an empty file".


RE: HP 50g+ Emulator - Gerald H - 08-02-2015 05:49 PM

Drag & drop library onto stack.

Enter a zero, so stack is

Lib
0

then press STO & soft restart, library is stored in port 0 & attached..

Works for me.

No access to port 2 though.


RE: HP 50g+ Emulator - matthiaspaul - 08-09-2015 12:01 AM

(08-01-2015 05:32 AM)Skyblues Wrote:  As discussed in the post "Emulator of HP 50g with #2.16 ROM", Hewlett-Packard released an HP-50G emulator that uses ROM version 2.16. I don't know what's different in v2.16 (if anything).
For those interested, this is the original thread:

http://www.hpmuseum.org/forum/thread-4405-post-39600.html

Greetings,

Matthias


RE: HP 50g+ Emulator - matthiaspaul - 08-09-2015 11:14 AM

(08-02-2015 04:49 AM)Tim Wessman Wrote:  If I remembered correctly, it had a new version of the streamer software to support the ss410 (as opposed to the ss400 earlier). Nothing else changed.
Tim, it would be great, if you could recheck and confirm this, so we know for sure, that this 50g ROM 2.16 is actually of HP origin, not some user-patched file.

Also, if the 2.16 ROM really supports the SS410 (or SS400), it would be great if HP could make it available outside the emulator as well. I would certainly like to use a SS410 (or SS400) with the one of my 50g, but despite HP's ads showing the 50g connected to a SS400, I have not seen a single user report not stating that it didn't worked for them (even with 2.15), so I never went out to buy a StreamSmart... (I know that the Prime supports the SS410, but for as long as the Prime does not at least support User RPL...)

Greetings,

Matthias


RE: HP 50g+ Emulator - Gerald H - 08-09-2015 11:22 AM

(08-09-2015 11:14 AM)matthiaspaul Wrote:  
(08-02-2015 04:49 AM)Tim Wessman Wrote:  If I remembered correctly, it had a new version of the streamer software to support the ss410 (as opposed to the ss400 earlier). Nothing else changed.
Tim, it would be great, if you could recheck and confirm this, so we know for sure, that this 50g ROM 2.16 is actually of HP origin, not some user-patched file.

Also, if the 2.16 ROM really supports the SS410 (or SS400), it would be great if HP could make it available outside the emulator as well. I would certainly like to use a SS410 (or SS400) with the one of my 50g, but despite HP's ads showing the 50g connected to a SS400, I have not seen a single user report not stating that it didn't worked for them (even with 2.15), so I never went out to buy a StreamSmart... (I know that the Prime supports the SS410, but for as long as the Prime does not at least support User RPL...)

Greetings,

Matthias

Dear matthiaqspaul,

How many negatives can you not put in one sentence?

"...I have not seen a single user report not stating that it didn't worked for them (even with 2.15), so I never went out to buy a StreamSmart..."

I don't have problems not understanding the sentence, but if you didn't use so many non-positives I might not have bothered to write this comment.


RE: HP 50g+ Emulator - Skyblues - 08-09-2015 10:38 PM

(08-09-2015 11:22 AM)Gerald H Wrote:  
(08-09-2015 11:14 AM)matthiaspaul Wrote:  Tim, it would be great, if you could recheck and confirm this, so we know for sure, that this 50g ROM 2.16 is actually of HP origin, not some user-patched file.

Also, if the 2.16 ROM really supports the SS410 (or SS400), it would be great if HP could make it available outside the emulator as well. I would certainly like to use a SS410 (or SS400) with the one of my 50g, but despite HP's ads showing the 50g connected to a SS400, I have not seen a single user report not stating that it didn't worked for them (even with 2.15), so I never went out to buy a StreamSmart... (I know that the Prime supports the SS410, but for as long as the Prime does not at least support User RPL...)

Greetings,

Matthias

Dear matthiaqspaul,

How many negatives can you not put in one sentence?

"...I have not seen a single user report not stating that it didn't worked for them (even with 2.15), so I never went out to buy a StreamSmart..."

I don't have problems not understanding the sentence, but if you didn't use so many non-positives I might not have bothered to write this comment.

Wow, unbelievable.
I think Matthias is German. I wonder how good your German is.

Haben Sie einen schönen Tag.


RE: HP 50g+ Emulator - Massimo Gnerucci - 08-10-2015 06:06 AM

(08-09-2015 10:38 PM)Skyblues Wrote:  Wow, unbelievable.
I think Matthias is German. I wonder how good your German is.

Haben Sie einen schönen Tag.

Gerald is Austrian, so I think his German should be quite good... ;)


RE: HP 50g+ Emulator - Guenter Schink - 08-10-2015 09:33 PM

(08-10-2015 06:06 AM)Massimo Gnerucci Wrote:  
(08-09-2015 10:38 PM)Skyblues Wrote:  Wow, unbelievable.
I think Matthias is German. I wonder how good your German is.

Haben Sie einen schönen Tag.

Gerald is Austrian, so I think his German should be quite good... Wink

I'll be at Vienna in October. As a real native speaker of German, I could perhaps evaluate Geralds knowledge of our common language.

SCNR and just kidding, Günter


RE: HP 50g+ Emulator - Thomas Klemm - 08-10-2015 10:09 PM

(08-09-2015 11:22 AM)Gerald H Wrote:  Dear matthiaqspaul,

(08-10-2015 09:33 PM)Guenter Schink Wrote:  As a real native speaker of German, I could perhaps evaluate Geralds knowledge of our common language.

Another native speaker of German chimes in: I might be able to evaluate Gerald's knowledge of spelling German names. Though I must admit that I have never been to Vienna.

Kind regards
Thomas


RE: HP 50g+ Emulator - Gerald H - 08-11-2015 05:40 AM

This thread seems to have swerved into a quagmire of my linguistic ability.

I wanted to admonish the use of the negative for a few reasons:

Thinking positive can become a (good) habit, the same for negative thinking & speaking, except that I call that a bad habit;

The grammar of negatives is more difficult than positives in European languages;

Negatives are often longer than positives;

Particularly politicians, but also girlfriends, employees & employers, who tell me what they don't want or won't do cause me irritation;

Most people have problems understanding sentences with multiple negatives - indeed, some psychologists/psychiatrists feel the id ignores all negatives;

Plus more reasons.....

I'd be pleased to meet any members of the Forum coming to Vienna for a chat, we could try to find a most convenient language then.

I would have hoped my linguistic abilities convinced all of you that I'm a second Shakespeare.

I think it best to start a new thread for the linguistic concerns & return to the emulator question in this one.


RE: HP 50g+ Emulator - matthiaspaul - 08-11-2015 08:38 PM

(08-11-2015 05:40 AM)Gerald H Wrote:  I would have hoped my linguistic abilities convinced all of you that I'm a second Shakespeare.
Except for that Shakespeare was quite undecided on the topic as well: To be or not to be. This is the question! ;->

Greetings,

Matthias


RE: HP 50g+ Emulator - Eric Rechlin - 08-15-2015 08:45 PM

I finally got VC6 installed and working again (on Windows 10, amazingly) and therefore was able to compile Emu48+ version 1.55. I've now added it to my site.


RE: HP 50g+ Emulator - Skyblues - 08-16-2015 01:02 AM

(08-15-2015 08:45 PM)Eric Rechlin Wrote:  I finally got VC6 installed and working again (on Windows 10, amazingly) and therefore was able to compile Emu48+ version 1.55. I've now added it to my site.

Hi Eric,

Thanks for sharing this information. I've been spending a lot of time lately with the 50g emulator trying to understand the different configurations.

Can you please tell what the difference is between:

1) Emu48+ Service Pack to 55 on HP 48/PC/Emulators (the one you are referring to)
2) Emu48 Service Pack to 57 on HP 48/PC/Emulators

I guess the question is, what is the difference between the Emu48 and Emu48+?

Thank you,
Jim


RE: HP 50g+ Emulator - Eric Rechlin - 08-20-2015 03:15 AM

The only real difference is that 55+ emulates the 49g+/50g and 57 does not. They are on the same code base. There's also a difference related to low battery reporting that I haven't bothered to test and merge, but otherwise the code is identical between the two.

Honestly, the version numbering would make more sense if 55+ were just bumped up to 57+, skipping a couple versions, but I wasn't the one who decided on the numbering.