HP Forums
WP-34S Emulator (Seg Fault) - Printable Version

+- HP Forums (http://www.hpmuseum.org/forum)
+-- Forum: Not HP Calculators (/forum-7.html)
+--- Forum: Not quite HP Calculators - but related (/forum-8.html)
+--- Thread: WP-34S Emulator (Seg Fault) (/thread-3013.html)



WP-34S Emulator (Seg Fault) - BarryMead - 02-05-2015 07:59 PM

When I run the wp34sgui.exe under wine in linux, and try to copy a number into the clipboard by right clicking on the logo and selecting "Copy Number" I get a SegFault error and the program has to end.

I am using Debian Lenny, with wine version 1.5.31. Does anyone else experience troubles copying a number to the clipboard while running the NON-QT windows emulator under wine?

The QT emulator copies numbers to the clipboard just fine under wine, it is only the NON-QT emulator wp34sgui.exe that has the issue. Incidentally the "Copy Textline" does not work either, (just copies strange square boxes
instead of the text, but does not seg fault). The "Copy Screen to Clipboard" does work perfectly. Also the emulator's "Copy Number" features work fine under native windows 7, it only fails in Linux under wine.


RE: WP-34S Emulator (Seg Fault) - Bit - 02-06-2015 01:54 AM

(02-05-2015 07:59 PM)BarryMead Wrote:  When I run the wp34sgui.exe under wine in linux, and try to copy a number in the to the clipboard by right clicking on the logo and selecting "Copy Number" I get a SegFault error and the program has to end.

I am using Debian Lenny, with wine version 1.5.31. Does anyone else experience troubles copying a number to the clipboard while running the NON-QT windows emulator under wine?
(1.4.1 in my case)
The QT emulator copies numbers to the clipboard just fine under wine, it is only the NON-QT emulator wp34sgui.exe that has the issue. Incidentally the "Copy Textline" does not work either, (just copies strange square boxes
instead of the text, but does not seg fault). The "Copy Screen to Clipboard" does work perfectly.
Confirmed: For the most part, the Windows version of the emulator works well under Wine but those two functions indeed fail. Other programs running under the same version of Wine (1.4.1 in my case) don't have this problem.


RE: WP-34S Emulator (Seg Fault) - BarryMead - 02-06-2015 03:45 AM

(02-06-2015 01:54 AM)Bit Wrote:  [Other programs running under the same version of Wine (1.4.1 in my case) don't have this problem.
I agree, I use the clipboard on windows programs under wine all the time. I am not sure what it is about the NON-QT emulator that confuses wine. I was hoping that someone might know how the QT and NON-QT emulators are different in how they handle the clipboard thinking that this might give us a clue.


RE: WP-34S Emulator (Seg Fault) - garfy - 02-14-2015 12:51 AM

do you have a link to download a wp34s.exe
for windows xp sp3 ?
i just buy and wait for this calculator .. Smile
thank you


RE: WP-34S Emulator (Seg Fault) - Didier Lachieze - 02-14-2015 06:23 AM

It's on Sourceforge.

BTW, the link on Soiurceforge to the printed manual should be updated now that the v3.3 is available.


RE: WP-34S Emulator (Seg Fault) - Marcus von Cube - 02-14-2015 10:11 AM

(02-14-2015 06:23 AM)Didier Lachieze Wrote:  It's on Sourceforge.

BTW, the link on Soiurceforge to the printed manual should be updated now that the v3.3 is available.

Here is the link to the Qt emulator written by Pascal Méheut:

http://sourceforge.net/projects/wp34s/files/emulator/wp-34s-emulator-windows.zip/download