The Museum of HP Calculators

HP Forum Archive 21

[ Return to Index | Top of Index ]

WP34s - CLP Problem
Message #1 Posted by John Abbott (S. Africa) on 27 Feb 2012, 4:13 a.m.

Hi, I am running WP34s 3.0 2584,and flashed with "calc_full.bin". Not sure if I am doing something incorrectly or if this is a bug, but if I try and delete a program in the library using CLP, the message "Sure?" appears but the calculator freezes and can only be restored with a reset. After reset, all programs in library are deleted. I have noticed this with a previous version as well (2582???)
Thanks John

      
Re: WP34s - CLP Problem
Message #2 Posted by Alexander Oestert on 27 Feb 2012, 4:18 a.m.,
in response to message #1 by John Abbott (S. Africa)

You have pressed Y, I assume?!

            
Re: WP34s - CLP Problem
Message #3 Posted by John Abbott (S. Africa) on 27 Feb 2012, 4:34 a.m.,
in response to message #2 by Alexander Oestert

Hi Alexander, yes but calculator appears to have already frozen and does not accept input. In fact I have pressed all the keys with no effect. I have successfully accomplished this with earlier revisions. Really a nice feature.
Thanks John

      
Re: WP34s - CLP Problem
Message #4 Posted by fhub on 27 Feb 2012, 5:47 a.m.,
in response to message #1 by John Abbott (S. Africa)

I've just tried it in the emulator (CLP for a program in the library), and in the emulator it works without problems.

      
Re: WP34s - CLP Problem
Message #5 Posted by Paul Dale on 27 Feb 2012, 5:52 a.m.,
in response to message #1 by John Abbott (S. Africa)

I'm seeing this too. One for Marcus.

- Pauli

            
Re: WP34s - CLP Problem
Message #6 Posted by John Abbott (S. Africa) on 27 Feb 2012, 6:09 a.m.,
in response to message #5 by Paul Dale

Hi Pauli, strange. Now that the flash is cleared, if I input two sample programs and store them in flash, and then delete either or both, it works. Something obviously to do with "calc_full.bin".
Thanks for all the replies.
Regards John

            
Re: WP34s - CLP Problem
Message #7 Posted by Marcus von Cube, Germany on 27 Feb 2012, 11:44 a.m.,
in response to message #5 by Paul Dale

It's fixed now. It was an alignment issue. The ARM processor does not like 32 bit access on a 16 bit boundary. :-(

The latest release has a minor keyboard update: SHOW now starts the register browser. Use <( and )> to view all digits of a number. The latter work even in the browser. )> shows the last 18 digits of a double precision number. In single precision mode it's just the same as <(.

SHOW in program mode to display the CRC is gone for now. Maybe it will come back later when the op-codes have settled a little more.

The yellow arrow (f EXIT) goes directly to lower case alpha mode. The key used to start the register browser but SHOW seems to be a better choice for this.

                  
Re: WP34s - CLP Problem
Message #8 Posted by John Abbott (S. Africa) on 27 Feb 2012, 1:10 p.m.,
in response to message #7 by Marcus von Cube, Germany

Thanks Marcus
John


[ Return to Index | Top of Index ]

Go back to the main exhibit hall