The Museum of HP Calculators

HP Forum Archive 18

[ Return to Index | Top of Index ]

HP41 display segments fail
Message #1 Posted by JoseL on 7 Feb 2008, 6:05 a.m.


A few months ago I purchased a HP41C with problems, to try to repair it.

The contacts of the batteries were completely oxidized. First I washed everything with isopropyl alcohol and repaired contacts with copper adhesive tape.

After installing the battery pack, the calculator switched on OK.

But the display had little contrast and there were several segments that failed.

After runnig the Service Module tests, all the tests went OK. Even the Display Driver test.

I removed and disassembled the display module. Cleaned the zebra connector and the driver PCB with isopropyl alcohol. Pressed a little the assembly clips.

I mounted the display on the calculator, and turned it on. It was alive!! I noted that the display contrast was already OK. Many of the segments that failed before, now are OK. But yet there are a couple of segments unstables and sometimes do not light.

Do you have any idea to help me to repair the display? What else can I do?

Thanks Jose

Re: HP41 display segments fail
Message #2 Posted by Randy on 8 Feb 2008, 8:53 a.m.,
in response to message #1 by JoseL

The worst 41 problem to troubleshoot...

Bad/missing/dim segments can be either a bad driver, bad lcd or bad connections. The usual culprit is the LCD itself. The only method to troubleshoot is to exchange both with known good parts, changing each one and retesting. Very tedious.

A caution: There are many different versions of the display and driver, some are incompatible with each other, some require a capacitor change on the logic board. Worst case is that you may need both parts together as a set along with a logic board. Best case is that the replacement parts you find are the same type as what you have.

Be aware that display problems are common on units with battery leakage. Buying another non-working unit is not always the best way to get parts.

Edited: 8 Feb 2008, 9:00 a.m.

Re: HP41 display segments fail
Message #3 Posted by JoseL on 11 Feb 2008, 4:34 a.m.,
in response to message #2 by Randy

Thanks for the response, Randy.

So, it is difficult to resolve this problem. IŽll try again to clean the zebra connector. I think the driver is OK.

Maybe the connector is slightly deformed and there is not good electric connection between the driver and the LCD.

Best regards.


[ Return to Index | Top of Index ]

Go back to the main exhibit hall