The Museum of HP Calculators

HP Forum Archive 15

[ Return to Index | Top of Index ]

is this normal in a repaired 41CX?
Message #1 Posted by Gonzalo Fernandez (Spain) on 4 Mar 2006, 5:04 p.m.

I have an HP41CX fullnut I repaired (changed bad memory chip, only 255 registers instead 319 registers) Now the repaired 41CX has 319 registers and 124 extended registers, the time clock works OK. The problem is after not using the calculator for 1-2 days (without batteries), when I put batteries, the screen shows all characters @, "@@@@@@@@@@@@", twelve @ characters. After this, pressing the backspace keys, the calculator powers off. From this point, I can turn on the calculator (ON key, the screen shows 0.0000) but I cannot do a reset (ON + backspace), only after 1-2 minutes I can do a reset (ON + backspace) and the calculator works perfectly.

What is due the initial showing (twelve @ characters) when I put batteries after not using the calculator for 2 days and stored without batteries? Im sure that is not due to a bad contact between the two halves of the calculator.

      
Re: is this normal in a repaired 41CX?
Message #2 Posted by Klaus on 6 Mar 2006, 7:01 a.m.,
in response to message #1 by Gonzalo Fernandez (Spain)

Hola Gonzalo!

I once got a 41CX fullnut for repair, with the display showing '@@@@@@@@@@' and I think the buzzer hummed a bit when switching on. I measured the signal lines and I think two of them had very low signal (about 200 mV if I recall correctly), and much noise on them. Since I did not have any replacements (As the lines connect CPU,RAM and ROM, any of the chips could have had a defect), I gave it back to the owner and he wanted to sell it on ebay.

I was also sure it weren't the contacts, as I opened the case an clamped the boards together with a 'monkey wrench?' (<= correct word???).

Perhaps you bad memory chip shorted some signal to ground and thereby damaged another chip? I think you should check your signals if you have access to a scope.

Good luck!

            
Re: is this normal in a repaired 41CX?
Message #3 Posted by Thomas Okken on 6 Mar 2006, 11:04 a.m.,
in response to message #2 by Klaus

Quote:
I was also sure it weren't the contacts, as I opened the case an clamped the boards together with a 'monkey wrench?' (<= correct word???).

This is a monkey wrench:

I think the word you were looking for is "vise":

                  
Thanks
Message #4 Posted by Klaus on 6 Mar 2006, 11:31 a.m.,
in response to message #3 by Thomas Okken

Thanks Thomas,

'vise' was the word!

wise advise! Klaus


[ Return to Index | Top of Index ]

Go back to the main exhibit hall